Checkout the headache by PayPal


#1

@SaintSovereign I have this issue that needs sorting.

I want to pay for a sub, but pressing the PayPal checkout button has a few issues.

Since PayPal doesn’t automatically fill in my address details on your page I must do so. But when I get the error message to fill in my details, I can’t, as it’s absent.

It’s possible to press the green checkout button, manually fill in the details, THEN press PayPal for it to go through, but damn…

Also noticed the download limit is back in place, any reason why? Q related?


#2

The paranoid in me got me checking my account. Some subs have a download limit while others do not. Must be a bug?


#3

For SMX? It’s a bit overkill for that?
Must be because of the Q piracy.


#4

That’s just it. Isn’t SMX2 using weapon-X tech? Maybe they’re porting SM to Q?


#5

@Michel the same happened for me. I emailed support, but never got a reply.

But then, I used incognito mode to make payment, and it worked


#6

We’re trying to figure out the PayPal issue. It’s a glitch with the plugin.


#7

Older subs still have the limit because I haven’t had the time to go through and remove them.


#8

I am unable to continue after the Paypal Process. It comes up with this screen. The fields that need to be filled out are not showing up to be filled out in the first place. I also have my addresses filled out in my profile under addresses.


#9

I was able to make a purchase. Pressing cancel and then redoing process works.


#10

We’re working on it. Not sure what the issue is.


#11

I noticed it happens if you are already “logged in” “remember me” in your broswer and you use paypal option.

This goes away if you go into incognito mode, try logging in and then make the purchase.


#12

I can’t seem to replicate the issue. Did you go to the checkout page first by clicking the green “checkout” button, or did you click the yellow “PayPal” button?


#13

I pressed the yellow paypal button.

It takes you to a PayPal log in window, then that redirects to confirm acceptance of amount transferred and then it takes back to the checkout page.

If you want I can screen record the process and send it to you.


#14

This has happened to me, but I just refreshed and logged-in (similar to what @mecharc recommends) until it worked. It was clearly that when the page was refreshed, or loaded from a memory cache, the address information was not reloading with it. I actually consider that to be a good thing.


#15

Ditto for me. I log in, then press the PayPal button to checkout.


#16

I had the same problem, now I press the “checkout” button instead of going directly to the yellow paypal button. Then all the necessary fields are filled out and I chose paypal instead of credit card. This seems to work even when I am logged in.


#17

ah, right. This is the actual solution. Thanks for pointing this out @Matt. I forgot about this step.


#18

Just a heads up, hopefully this is fixed. It was an issue with the plugin we use to process PayPal payments. They just released an update that ALLEGEDLY fixes this.